March 2021 CU for SharePoint Server 2019 is available for download

The product group released the March 2021 Cumulative Update for SharePoint Server 2019 product family. SharePoint Server 2019 is patched with a language dependent and a language independent fix.

The KB article for March 2021 CU will be available at the following Location in a couple of hours:

  • KB 4493230 – March 2021 Update for SharePoint Server 2019 (language independent) – This is also a security update!
  • KB 4493231 – March 2021 Update for SharePoint Server 2019 (language dependent) – This is also a security update!

The download for March 2021 CU is available through the following link:

Important: It is required to install both fixes (language dependent and independent) to fully patch a SharePoint server. This applies also to servers which do not have language packs installed. The reason is that each SharePoint installation includes a language dependent component together with a language independent component. If additional language packs are added later (only) the language dependent fix has to be applied again.

It is irrelevant which language you pick on the drop down in download center. Even the language dependent fixes are all in the same package for all languages.

After installing the fixes you need to run the SharePoint 2019 Products Configuration Wizard on each machine in the farm. If you prefer to run the command line version psconfig.exe ensure to have a look here for the correct options.

Please ensure to have a look at the SharePoint Patching Best Practices before applying new fixes.

SharePoint 2019 March 2021 CU Build Number:

Language independent fix: 16.0.10372.20060
Language dependent fix: 16.0.10372.20060

Related Links:

20 Comments


  1. Hi Stefan, March 2021 CU cause an issue when I trying to delete attachment from list item. attachment still appear and nothing change on the screen, Is this a known isssue?

    Thanks

    Reply

    1. Hi,
      this is not a known issue. I would suggest to open a ticket with Microsoft to get this analyzed.
      Cheers,
      Stefan

      Reply

      1. I have the same issue with the attachments after installing the March 2021 CU.

        Reply

        1. Please ensure to open a ticket for this with Microsoft.

          Reply

          1. Unfortunately i have the same behavior on multiple sharepoint 2019 farms

            Any know fix other than using classic view

            Thanks


          2. I have the same problem in multiple sharepoint 2019 farms… any fix other than the classic view

            Thanks


          3. Hi Hesham,
            to get this analyzed and fixed this needs to be raised to Microsoft through a support case.
            Cheers,
            Stefan


          4. We have created a support case with MS and they were able to reproduce this behavior.
            The engineering team will take further actions.


          5. Thanks Danny!
            Would be great if you could send me the SR number using the “Contact the blog author” option at the top right to allow me to monitor this issue.


          6. I just received feedback by MS that this issue will be resolved in the May 2021 CU.


          7. Hi Danny,
            I received the same response.
            You can find the info further down in the comments for this thread.
            Cheers,
            Stefan


    2. Did you open a ticket? I can confirm that I have the same issue.

      Reply

    3. The problem only occurs in modern view. When switching back to classic view I can delete the attachments.

      Reply

    4. A quick update: the fix for the issue with the deletion of the list item attachments in modern view is planned to be included in May 2021 CU.

      Reply

  2. Hi Stefan,

    If I install both patches (independent and dependent) and after that I install a language pack, is the patch still valid? Or does installing a language pack overwrite the patch files?

    Reply

    1. Hi Danny,
      the language pack does not overwrite the patches – but the new language pack was never patched with the language dependent patches. So you need to reapply the language dependent one to get the files from the new language pack updated.
      Cheers,
      Stefan

      Reply

  3. i am having the same issue as well ( on multiple sharepoint 2019 farms)

    Reply

    1. Hi Hesham,
      to get this analyzed and fixed this needs to be raised to Microsoft through a support case.
      Cheers,
      Stefan

      Reply

  4. In case someone else was pulling their hair while trying to figure out why crawled properties don’t appear: it looks like this CU fixes that. We’re planning a migration and I made a new farm originally last September, and was at my wits’ end trying to figure out why crawled properties didn’t appear, even though pages were crawled just fine.

    Several months of research, reinstalling and reconfiguring later – tried no CU at all (worked), September 2019 CU (worked), August 2020 CU (didn’t work) and January 2021 CU (didn’t work) – and finally we can move forward!

    But even with this one we had some issues: you have to set the crawling account as a site collection administrator to get some columns to work. Web application administrator won’t be enough. We’ll see if future updates change that.

    Reply

Leave a Reply to DLacto Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.