October 2020 CU for SharePoint Server 2016 is available for download

The product group released the October 2020 Cumulative Update for SharePoint Server 2016 product family.

This CU also includes Feature Pack 1 which was released with December 2016 CU and Feature Pack 2 which was released with September 2017 CU.

The KB articles for October 2020 CU are available here:

  • KB 4486677 – October 2020 Update for SharePoint Server 2016 (language independent) – This is also a security update!
  • KB 4486681 – October 2020 Update for SharePoint Server 2016 (language dependent)

The download for October 2020 CU is available here:

Important: It is required to install both fixes (language dependent and independent) to fully patch a SharePoint server. This applies also to servers which do not have language packs installed. The reason is that each SharePoint installation includes a language dependent component together with a language independent component. If additional language packs are added later (only) the language dependent fix has to be applied again.

It is irrelevant which language you pick on the drop down in download center. Even the language dependent fixes are all in the same package for all languages.

After installing the fixes you need to run the SharePoint 2016 Products Configuration Wizard on each machine in the farm. If you prefer to run the command line version psconfig.exe ensure to have a look here for the correct options.

SharePoint 2016 October 2020 CU Build Numbers:

Language independent fix: 16.0.5071.1000
Language dependent fix: 16.0.5071.1000

To understand the different version numbers please have a look at my article which explains the different SharePoint build numbers.

Please ensure to have a look at the SharePoint Patching Best Practices before applying new fixes.

Related Links:

27 Comments


  1. Hello Stefan,

    I have successfully installed October cumulative updates KB4486677 but now I can’t browse Central Administration site. I have checked IIS/AppPool and required services, apparently everything is up and running. Other web applications sites are accessible and I am able to browse it within/ outside of the server. Can you suggest me a resolution/ workaround ?

    Thanks in advance,
    Waseem

    Reply

    1. Hi Waseem,
      I haven’t see this issue so I cannot give you any advise.
      What error do you get when trying to browse to the Centra Admin?
      Cheers,
      Stefan

      Reply

      1. Hello Stefan,

        I am getting HTTP 403 Forbidden, The website declined to show this webpage .

        Best wishes,
        Waseem

        Reply

        1. Hi Waseem,
          this is a very generic error. I would suggest to investigate by looking in the ULS log to see if you can find out what is causing the issue.
          If you need assistance I would recommend to open a ticket with Microsoft support.
          Cheers,
          Stefan

          Reply

  2. Hello, thanks for all.
    With a customer I opened a case [Case #:21544828] It was about the fact the library setting Open in Client is not honored in modern browsers Chrome, Edge Chromium. Files are open in browser with Office Online Server instead. .The fix was supposed to be included in Oct CU but I dont see this fact is the KB.
    I’m wrong ?
    Thanks Regards
    EtienneL

    Reply

    1. Hi Etienne,
      I double checked: the fix was planned for October CU but the product group managed to fix it faster and the fix was already released with September CU.
      You can find the documentation here:
      https://support.microsoft.com/en-us/help/4484506/security-update-for-sharepoint-server-2016-sept-8-2020

      Fixes an issue in which the library setting that should force opening a document in Word is not honored in classic experience when you use browsers other than Internet Explorer or legacy Edge.

      Cheers,
      Stefan

      Reply

  3. Perfect, thanks Stephan

    Reply

  4. Hi Stephan,

    This is my first comment in the blog, though I am experienced in SharePoint Administration.

    With respect to Oct Cu, I have just applied KB 4486677, and everything works fine. What will be the implications, if we don’t apply the KB 4486681.

    Regards

    Reply

    1. Hi Abdul,
      some fixes will not reach your system and some functionality might be broken if the code requires updated language strings (in the UI you might see missing strings).
      Cheers,
      Stefan

      Reply

  5. Hello Stefan,
    After installing October CU on one of our 2016 farms, We have an issue with creating new list forms using SharePoint Designer. we get the oblivious error “Could not save list changes to server” . did you see this kind of error before? all i can find about this error is with SharePoint Online and not 2016.
    Thanks
    Guy

    Reply

    1. Hi Guy,
      I haven’t heard about this so far.
      If you need assistance I would recommend to open a support ticket to get this analyzed.
      Cheers,
      Stefan

      Reply

  6. After installed the october patch in SharePoint 2016, Large file upload (>100 MB) not working. any fix for this?

    Reply

  7. Hi, After this october patch(kb4486677), open documents from Client Application is not working even after feature for open document in Client program by default is activated. Any fix for this?

    Reply

    1. Hi Banu,
      I just tested and it works fine for me.
      I would suggest to open a ticket with Microsoft to get this analyzed.
      Cheers,
      Stefan

      Reply

  8. Hi Stefan,
    Thanks for your reply.
    It works fine in document Library, but when document webpart is added to the page, document doesnot open in client application. Could you please check this?
    Regards
    Banu

    Reply

    1. Hi Banu,
      I just did a couple of tests and all of them were successful.
      Here is what I tested:

      Classic Team Site:
      – open document in library in classic view -> correctly opens in client application
      – open document in library in modern view -> correctly opens in client application
      – classic document library web part on the Home.aspx page -> correctly opens in client application

      Modern Team Site:
      – open document in library in classic view -> correctly opens in client application
      – open document in library in modern view -> correctly opens in client application
      – modern document library web part on the Home.aspx page -> correctly opens in client application

      So I was not able to repro the issue.

      I would suggest to open a ticket with Microsoft to analyze what is causing the issue in your environment.

      Cheers,
      Stefan

      Reply

      1. Thanks a lot for using your time and effort.
        Regards
        Banu

        Reply

    1. Hi Rui,
      from my understanding you need to follow the guidance in this article to fix the issue.
      Cheers,
      Stefan

      Reply

  9. Hi Stephen,

    we are planning to install October 2020 CU update in our SharePoint 2016 servers.
    Can you please let us know if this CU also include security update for Microsoft SharePoint Server Remote Code Execution Vulnerability which was reported on 9th June 2020.

    Reply

    1. Hi Sobhash,
      can you please send me the CVE for the vulnerability you are referring too?
      Thanks,
      Stefan

      Reply

        1. Hi Sobhash,
          the fix for this vulenarability was already included in June CU and is of course also included in October CU as SharePoint fixes are cumulative.
          Cheers,
          Stefan

          Reply

          1. Thanks Stephen

Leave a Reply to Waseem Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.