Heads-Up: Info on unsupported .NET framework versions (e.g. in SharePoint environments)

In the last two months I have worked on several SharePoint issues where we identified that the servers running SharePoint were still using .NET framework 4.5 or .NET framework 4.5.1 which are unsupported since around a year (supported ended January 12th, 2016 as announced in August 2014):

Currently only .NET 4.5.2, 4.6, 4.6.1 and 4.6.2 are supported:

Please ensure to verify that the servers in your environments use a supported .NET framework version.
Be aware that aside normal fixes also no security fixes will be released for .NET 4.5 and .NET 4.5.1 as these versions are out of support!
 
More Info:

 

9 Comments


  1. Stupid question, but does this mean that in order to get support, we would also need to have the latest .net framework installed?

    Reply

    1. Hi Rob,
      in order to get support you need to have a supported Software installed – I guess that should be obvious. 😉
      It does not have to be the latest but it has to be one of the supported .NET framework versions.
      Cheers,
      Stefan

      Reply

  2. Hi, you can use this PowerShell command to check the version:
    ($p = Get-ItemProperty “hklm:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full”).Release

    Reply

  3. Hi
    Does SharePoint 2013 Support 4.5.2 – 4.6.2
    Would you recommend increment or go to the latest support version that works with SP2013

    Reply

    1. Hi Steven,
      if you are not yet on 4.5.2 – 4.6.2 you are unsupported. And that since more than a year.
      There are also no security fixes for anything before 4.5.2 since a year. So a system which is on an older .NET version is potentially open to various security issues.
      And sure: SharePoint 2013 supports .NET 4.5.2 – 4.6.2.
      My suggestion would be to evaluate 4.6.2.
      If you have customizations or 3rd party components ensure to get supportability information for these components as well.
      And don’t forget to test before you apply the updates – as always.
      Cheers,
      Stefan

      Reply

      1. Hi
        problem is only that you need to use a 4.5x if you want to install SharePoint Server 2013 – what we still do……
        Christoph

        Reply

  4. I develop SharePoint Add-in in Visual Studio 2017. Unfortunately SharePoint Online Add-in project still allows selection only of old .NET 4.5.2. I have many reference projects that are in 4.6.2. This is painful to switch .NET framework for the same projects reused in SharePoint (4.5.2) and other solutions (using 4.6.2). When will SharePoint Online Add-in start to support 4.6.2?

    Reply

  5. Is there any kind of page in Microsoft Docs that lists all the .NET framework versions that are required or can work with the different SharePoint server versions?

    Reply

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.