MOSS – Common Issue – events 7076, 6398, 6482 listed in the Event log and/or IIS MMC not responding

We had a big number of cases where customers reported the following pattern:

Event ID 7076 –

Office SharePoint Server “Attempted to read or write protected memory. This is 
often an indication that other memory is corrupt. ” 
“System.AccessViolationException: Attempted to read or write protected memory. This 
is often an indication that other memory is corrupt.

Event ID 6398 – 

Windows SharePoint Services 3 NERA-WPWFE1 
“Microsoft.Office.Server.Administration.ApplicationServerAdministrationServiceJob 
“”cddd50c5-bf98-4496-85b5-d1c755e4dca7 ” 
“Exception from HRESULT: 0x80005006  
 
Event ID 6482 –
 
“Microsoft.Office.Excel.Server.ExcelServerSharedWebServiceInstance 
“”3ff29932-af40-4296-b012-eb71dee2c40e “”Attempted to read or write protected 
memory. This is often an indication that other memory is corrupt. “” 
System.AccessViolationException: Attempted to read or write protected memory. This 
is often an indication that other memory is corrupt. 

Some customers also reported that the IIS MMC stops responding and a restart of IIS is required to resolve the problem.

After some research we found that all these problems were caused by a problem in the IIS ADSI providers. A hotfix to resolve this issue is meanwhile available:

946517 – FIX: You may be unable to manage IIS 6.0 by using Server Manager if two threads access IIS 6.0 at the same time

16 Comments


  1. Nice Stefan,

    I never put the events together with the IIS going belly up and after running an IIS Reset it always came up clean and stayed clean for a while then would happen after a few months.  Great post.

    Reply

  2. I am getting a 6398 error in the event viewer. I am trying to mail enable a document library. When i do this within sharepoint it tells me error in application. Then when I look in event viewer under application, it gives me the 6398 error repeatedly.

    Can you help?

    Reply

  3. problem solved… it was proxy related, not moss related 🙂

    Reply

  4. I have same issue (events 7076, 6398 and 6482, IIS 7 manager is working, IIS 6 manager is not) in Windows Server 2008 and IIS 7.

    Reply

  5. We are also seeing this running sharepoint 64 bit on windows 2008

    Reply

  6. Hi Ian,

    then please open a support case for this so that we can escalate this and request a hotfix.

    Cheers,

    Stefan

    Reply

  7. Hi Stefan,

    Thanks for this info.. this one fixed the corrupted memory issue we were having.

    Cheers

    Ajay

    Reply

  8. Does anyone know of a fix for IIS 7 and Server 2008?

    Reply

  9. Hi Mike,

    till now nobody requested a fix for this for IIS 7 from Microsoft. So no hotfix has been created till now.

    If you need it, please open a support case and request the fix for IIS 7 to ensure that it is created.

    Cheers,

    Stefan

    Reply

  10. There is a fix available now for Windows 2008 (and Vista), although the kb article at http://support.microsoft.com/default.aspx/kb/946517 does not list it.

    At the top of the article you can find the "View and request hotfix downloads" link. Here you can find a fix for Vista, which can also be applied to Server 2008. This has been confirmed by Microsoft Support. Vista and Server 2008 share the same code.

    Reply

  11. hi Stephan,

    My doubt is generic , how can we easily find whether a later version of MS update/Rollup includes its old fixes.

    For eg: I want to know whether this fix is included in MOSS SP2 or June COD patches ?

    Pleasehelp me…

    Reply

  12. Hi Sarath,

    this fix is for IIS – not for MOSS. So it cannot be included in any MOSS fixes.

    Cheers,

    Stefan

    Reply

  13. Hi Stefan,

    I am running into this issue, and I have windows 2008 sp1 with adsiis.dll version 7.0.6002.18005 which is a later version that what is listed in the hotfix.  I tried to install the hotfix anyway, but a message appeared that The update does not apply to your system.  Any ideas?

    Reply

  14. Hi Jenn,

    a similar hotfix exists for IIS 7.

    Please open a support case with the IIS team to request it.

    Cheers,

    Stefan

    Reply

  15. Hi,

       we are facing the same problem on windows server 2008 R2 OS. if you have any solution it would be great

    thanks

    Ramu

    Reply

Leave a Reply to miras Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.